NEW PERSPECTIVES

PowerPoint Tutorial 1:

Creating a Presentation




Objectives

* Plan and create a new presentation

* Create a title slide and slides with bulleted lists
* Change the theme

* Open an existing PowerPoint presentation

* Edit and format text in the Slide pane

* Use AutoCorrect
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Objectives

* Rearrange text in the Outline tab

* Rearrange slides in Normal and Slide Sorter
view

* Delete slides

* View a slide show

* Create a new presentation based on an
existing one

 Animate slide titles and bulleted lists
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Objectives

* Apply transitions

* |Insert footer text, slide numbers, and the date
on slides

* Create speaker notes
* Check the spelling in a presentation

* Preview and print slides, handouts, speaker
notes, and the outline
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The PowerPoint Window
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The Slides tab shows a
column of numbered slide
thumbnails so you can see a
visual representation of
several slides at once.

The Close button closes the pane

containing the Slides and Outline tab.
To get it back, drag the bar that will
be along the left edge of the window.

Drag the scroll box in the Slides or
Outline tab to see different slides in

Thumbnails are miniature
images of each slide.
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The Notes pane contains
notes (also called speaker

notes) for the presenter to

the tab without changing the slide
displayed in the Slide pane.

3870 West Bear

refer to when delivering the
presentation.

The current theme is
Waveform. A theme is a
coordinated set of colors,
fonts, and other design
elements that are applied to
components of a presentation.

This area of the status bar
identifies the current slide
number and the total

4 ‘ Click to add notes

number of slides.
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aph Drawing Editing | the Slide pane vertical

scroll bar to move to
other slides.

The Slide pane shows
the current slide as it
will appear during your
slide show.

The Next Slide button allows

you to move to the next slide
in the presentation.

View buttons allow you to

switch to different views of

the presentation.

The Previous Slide
button allows you to
move to the previous
slide in the presentation.

The Fit slide to current
indow button resizes the

slide in the Slide pane to fit
in the window.
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Creating a New Presentation

* PowerPoint is a powerful presentation
graphics program that provides everything you
need to produce an effective side show
presentation that can be shown to an
audience of provided to people to view on
their own

* Click the Start button, point to All programs,
click Microsoft Office, and then click Microsoft
PowerPoint 2013
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Creating a New Presentation

Figure 1-1 Blank presentation in the PowerPoint window
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Creating a New Presentation

* Planning a presentations
—What is the purpose of your presentation?
—Who is your audience?

—How much time do you have for the
presentation?

— Will your audience benefit from printed
output?
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Creating a New Presentation

Figure 1-3 Built-in layouts in PowerPoint

Layout

Description

Title Slide
Title and Content

Section Header

Two Content
Comparison

Title Only
Blank
Content with Caption

Picture with Caption

Contains the presentation title and a subtitle; is usually used as the first
slide in a presentation

The most commonly used layout; can contain either a bulleted list or a
graphic in addition to the slide title

Contains a section title and text that describes the presentation section

The same as the Title and Content layout, but with two side-by-side con-
tent placeholders, each of which can contain a bulleted list or a graphic

The same as the Two Content layout, but includes text placeholders above
the content placeholders to label the content

Includes only a title text placeholder for the slide title
Does not contain any placeholders

Contains a content placeholder, a title text placeholder to identify the slide
or the content, and a text placeholder to describe the content; suitable for
photographs or other graphics that need an explanation

Similar to the Content with Caption layout, but with a picture placeholder
instead of a content placeholder
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Creating a New Presentation

* A bulleted list is a list of “paragraphs” with a
special character to the left of each paragraph

— Bulleted item
—First-level bullet
—Second-level bullet
* Subbullet
* As you add text to a content placeholder, the
AutoFit feature changes the line spacing and

the font size of the text if you add more text
than will fit in the placeholder
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Creating a New Presentation

Figure 1-8 AutoFit Options button menu
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Using Themes

* Theme colors are the colors used for the
background, title text, body text, accents,
background colors and objects, and graphics in
a presentation

* Theme fonts are two fonts or font styles, one
for the titles (or headings) and one for text in
content placeholders

* A graphic is a picture, shape, design, graph,
chart, or diagram
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Using Themes
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Editing Text

Selected text formatted with bold and a shadow effect
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Undoing Actions

* |f you make a mistake as you are working, you
can undo your error by clicking the Undo

button on the Quick Access Toolbar
Undo button menu

(Undo button arrowJ

FFFFF

list of recent actions;
yours might differ

®
. I+ Atimeshare co-op for recreational equipment
E;EA q i * Shared ownership of snowmobiles, boats,
- s i waverunners, ATVs, and other equipment ‘
i # Much less expensive than purchasing and maintaining
text dragged in mostw ¢ | , equipment )
recent action J @ oy I The convenience of ownership without the hassle
E Advantages
=] Use the equipment whenever you want

Take it wherever you want
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Using AutoCorrect

* The AutoCorrect feature automatically
corrects certain words and typing errors

Figure 1-15 AutoCorrect symbol on a slide

You want to enjoy great outdoors,
but you can’t afford a

Ski boat

* Canoe

d = I+ Kayak text moved to
| Waverunner create new

i Snowmobile bulleted item
1 RV

1 ATV

1 # Camping gear

KKK
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Editing Text in the Outline Tab

* Working in the Outline tab allows you to see
the outline of the entire presentation

* Promoting an item means moving an item
higher in the outline

* Demoting an item moves the item lower in the
outline
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Editing Text in the Outline Tab

New Slide 4 created by promoting text
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Rearranging Slides

* |n Slide Sorter view, PowerPoint displays all
the slides as thumbnails

* On the status bar, click the Slide Sorter button

* Dragging and dropping slides in Slide Sorter
view will rearrange them in the presentation
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Rearranging Slides

Figure 1-21 Moving a slide in Slide Sorter view
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Deleting Slides

* |n Slide Sorter view or in the Slides tab in Normal
view, right-click the slide thumbnail of the slide you
want to delete; or in the Outline tab in Normal view,
right-click the slide title of the slide you want to
delete

* On the shortcut menu, click Delete Slide

or

* |n Slide Sorter view or in the Slides tab in Normal
view, click the slide thumbnail of the slide you want
to delete; or in the Outline tab in Normal view, click
the slide icon of the slide you want to delete

* Press the Delete key
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Running a Slide Show

 Slide Show view displays each slide so that it fills the
entire screen with no toolbars or other Windows
elements visible on the screen

* When you click the Slide Show button on the status bar,
the slide show starts beginning with the current slide

* To start a slide show from the beginning, click the Slide
Show tab on the Ribbon, and then in the Start then Slide
Show group, click the From Beginning button

* In Slide Show view, you move from one slide to the next
by pressing the Spacebar, the Enter key, the = key, or
the Page Down key
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Running a Slide Show

Toolbar in Slide Show view

What is Share-My-Toys?

* Atimeshare co-op for recreational equipment

* Shared ownership of snowmobiles, boats,
waverunners, ATVs, and other equipment

* The convenience of ownership without the hassle

Next button

Slide Show menu
button

Previous button | >

toolbar in Slide Show 0
view (might be very
faint on your screen)
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Using Animations and Transitions

Use buttons on the Click the Start arrow to 1
Click the Preview Animations tab to apply change whether an animation
button on the animations, which are starts when you advance the Use buttons on the Transitions The Transition
Animations tab or special effects applied slide show (On Click), when the tab to apply transitions, special gallery contains
the Play Animations The Animation to an object, such as a previous item animates (With effects that change the way slides transitions that you
icon in the Slides gallery contains graphic or a bulleted Previous), or automatically appear during a slide show. can choose.
tab to preview animations you list, that makes the after the previous item
animations. can choose. object move. animates (After Previous).
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Creating a Presentation Based

Exicting P .

* Click the File tab to open Backstage view, and
then click the New tab in the navigation bar

* |n the Home section, click New from Existing
to open the New from Existing Presentation
dialog box

* Navigate to the drive and folder containing the
presentation on which to base the new
presentation, click the presentation file, and
then click the Create New button

* Save the new presentation
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reating a Presentation B

ased

Figure 1-26 The New tab in Backstage view
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Animating Text

e Animations add interest to a slide show and
draw attention to the text or object being
animated

— Progressive disclosure
* Animation effects are grouped into four types:
— Entrance
—Emphasis
— Exit
—Motion Paths
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Animating Text

* Modifying the Start Timing of the Animation of Subbullets

— In the Slide pane, click anywhere in the text box
containing the subbullets to make it active

— Click the Animations tab on the Ribbon, and then
apply an animation to the active text box

— In the Slide pane, select all the subbullets on the slide,
or select all the bulleted items on the slide, or click the
dashed line box surrounding the text box so it changes
to a solid line

— On the Animations tab, in the Timing group, click the
Start button arrow, and then click On Click or After

Previous
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Animating Text

Figure 1-28 Start timing for the Risks bullet on Slide 7
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Adding Transitions

* |In the Slides tab or the Outline tab in Normal
view or in Slide Sorter view, select the slide(s)
to which you want to add a transition, or, if
applying to all the slides, select any slide

* Click the Transitions tab on the Ribbon

* |n the Transition to This Slide group, click the
More button to display the gallery of transition
effects

* Click the desired transition effect in the gallery
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Adding Transitions

* |f desired, in the Timing group, click the
Transition Sound button arrow to insert a
sound effect to accompany each transition

* |f desired, in the Timing group, click the
Transition Speed button arrow to modify the
speed of the transition

* To apply the transition to all of the slides in
the presentation, in the Timing group, click the
Apply to All button
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Inserting Footers, Slide Numbers,
and the Date

* |n PowerPoint, a footer is text that appears on
every slide, but depending on the theme
applied, it might not always appear at the
bottom of a slide

* Click the Insert tab on the Ribbon

* |n the Text group, click the Header & Footer
button
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Inserting Footers, Slide Numbers,
and the Date

Figure 1-31 Slide tab in the Header and Footer dialog box
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Using Speaker Notes

* Notes (also called speaker notes) help the
speaker remember what to say when a
particular slide appears during the
presentation

* They appear in the Notes pane below the slide
pane in Normal view

* You can also print notes pages with a picture
of and notes about each slide
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Using Speaker Notes

Sides | Outline | X

4
w

#w

g~

o

Objectives

note in Notes pane Pass out marketing plan handouts

Slide6 of8 | Plan’ | D

Figure 1-33 Slide 6 in Notes Page view
s

Notes Page button

ETRE]

69% (=

“n 4

Normal

Notes6 of 8

“Plan”

Insert

@

Design

Objectives

slide thumbnail

.

note

Next Slide button

BRWUT %% (-

+
Eildn «

New Perspectives on Microsoft PowerPoint 2013

35



Checking the Spelling in a
Presentation

* Before you print or present a slide show, you
should always perform a final check of the
spelling of all the slides in your presentation

* PowerPoint does two types of spell-checking:

—The regular type is when PowerPoint finds a
word that’s not in its dictionary

—The other type is called contextual spell-
checking, which checks the context in which

a word is used
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Checking the Spelling in a

Presentation

Figure 1-35 Shortcut menu for a misspelled word
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Previewing and Printing a
Presentation

* PowerPoint provides several printing options:
— Color, grayscale, or pure black and white
— Full page slides
—Notes pages
—Outline
—Handouts
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Previewing and Printing a
Presentation

Figure 1-38 Print tab in Backstage view
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